• /
  • EnglishEspañol日本語한국어Português
  • ログイン今すぐ開始

この機械翻訳は、参考として提供されています。

英語版と翻訳版に矛盾がある場合は、英語版が優先されます。詳細については、このページを参照してください。

問題を作成する

データが報告されなくなる

問題

New Relic PHP エージェントは、以前はデータを報告していましたが、その後報告しなくなりました。さらに、このような

  • エージェント デーモン ログ ファイル/var/log/newrelic/newrelic-daemon.logを確認すると、メッセージLack of activity within 10msが表示されました。
  • アプリケーションの健康状態はグレーです。
  • アプリケーションを削除するオプションは、アプリケーションのSettingsメニューでアイコン。

解決

アプリケーションがアイドル状態にならないようにするには、これらの方法のいずれかを使用します。

  • newrelic.daemon.app_timeoutのタイムアウト値をトランザクション間隔の少なくとも 2 倍に設定します。たとえば、1 時間ごとのバックグラウンド ジョブの場合、タイムアウトを 2 時間に設定します。
  • 推奨事項: プロセスが長い場合や頻度が低い場合は、 phpinfo()などの単純なトランザクションを使用して、5 分ごとに cron ジョブを実行します。 これにより、アプリケーションがアイドル状態にならないことが保証されます。

重要

cron ジョブを無視するようにnewrelic_ignore_transactionを設定しないでください。ジョブが実行されずレポートも行われない場合、PHP エージェントはアイドル状態になります。

原因

アプリケーションのトランザクションに10分以上かかる場合や、10分に1回以下の頻度で発生する場合は、アプリケーションはアイドル状態になります。

PHP エージェントがアイドル状態の場合、レポートを再開する前にtwoトランザクションを実行する必要があります。

  • 最初のトランザクションでは、デーモンを起動し、New Relicへの接続を再確立します。
  • 2つ目のトランザクションは、New Relicにデータを報告します。
Copyright © 2024 New Relic株式会社。

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.