問題
New RelicのAmazon統合をセットアップした後、 CloudWatch APIの使用量が増加し、その後CloudWatchの使用料に影響を与えました。
解決
間違った ARN アカウントのインベントリ情報を収集していないことを確認してください。New Relic アカウントに関連付けられた ARN が正しいことを確認してください。
ポーリング頻度 は、New Relic がクラウドプロバイダーからデータを収集する頻度を決定します。デフォルトでは、ポーリング頻度は各サービスで利用可能な最大の頻度に設定されています。Amazon CloudWatch の請求書を管理する必要がある場合は、 ポーリング頻度を下げることができます。
AWSとのインフラストラクチャ統合のためのAPIの使用法を確認するには:
one.newrelic.com > All capabilities > Infrastructure > AWS > Account status dashboardに移動します。
ダッシュボードを確認します。
ダッシュボードには、直近1ヶ月のアカウントのAPIコール数と、直近1日のCloudWatch APIコール数(AWSリソースごと)がグラフで表示されます。この情報は、New Relic のみの API 使用量です。発生する可能性のある他の AWS API や CloudWatch の使用量は含まれていません。
どのサービスが請求額の増加の原因となるかを判断するには、New Relic のアカウント担当者にお問い合わせいただくか、 support.newrelic.com でサポートを受けてください。
原因
Amazon との統合では、CloudWatch を利用してメトリクスを収集します。AWS は、 月あたり最初の 100 万を超えるリクエストに対して共同顧客に料金を請求します。
CloudWatchの課金問題は、以下のいずれかが原因と考えられます。
- 同じサービスの複数のプラグインでAmazon統合を有効にする
- AWS統合に誤ったロールARNを追加する