問題
New Relic Infrastructure エージェントは、実際のFluent Bit再起動を行わずに過剰なFluent Bit Started
およびFluent Bit Stopped
イベントを送信しています。 これにより、ログが乱雑になり、監視の精度に影響し、データの取り込みが増加して、予期しない請求が発生する可能性があります。
原因
これは、インフラストラクチャエージェントのホスト名解決コンポーネントのバグが原因で発生します。 エージェントは頻繁なホスト名の変更を誤って検出し、 LogForwarderSupervisor
がこれらの誤った Fluent Bit 再起動イベントを送信するようにトリガーします。次の例のようなデバッグ メッセージが何千も表示される場合があります。
time="2024-04-20T02:46:47Z" level=debug msg="Notifying observers." change=2 component=HostnameResolvertime="2024-04-20T02:46:47Z" level=debug msg="Observer notified." component=HostnameResolver name=LogForwarderSupervisor
解決
この問題を解決するには、インフラストラクチャエージェントの設定で名ホスト解決の動作を変更します。 この修正は Windows システムと Linux システムの両方に適用されます。
次の設定をインフラストラクチャエージェント設定ファイルに追加します。
Linux : /etc/newrelic-infra.yml
Windows : C:\Program Files\New Relic\newrelic-infra\newrelic-infra.yml
dns_hostname_resolution: falseoverride_hostname: "your-server-hostname"
"your-server-hostname"
実際のサーバーホスト名に置き換えます。
この設定:
- 不安定なホスト名検出を引き起こす可能性のある逆DNSルックアップを無効にします
- エージェントに特定のホスト名の使用を強制し、ホスト名の変更検出を防止します。
設定を適用する
設定を追加した後:
設定ファイルを保存します。
New Relic Infrastructure エージェントを再起動します。
Linux:
bash$sudo systemctl restart newrelic-infraWindows :
Restart-Service newrelic-infra
検証
問題が解決されたことを確認するには:
- インフラストラクチャ エージェント ログを監視して、
HostnameResolver
メッセージが繰り返されていないかどうかを確認します。 - New Relic ダッシュボードをチェックして、
Fluent Bit Started
およびFluent Bit Stopped
イベントが継続的に表示されなくなっていることを確認してください。 - ログ転送が引き続き正常に機能し、ログが構成どおりに表示されることを確認します。